Vision Suite - Early ePOD Release Information

Incident Report for Vision Suite

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 22:39 GMT

Investigating

Google has released our Vision ePOD update 7 days ahead of the planned schedule.

All ePOD devices should receive a prompt to download the new version and normal functionality is expected to continue without interruption.

If you encounter any issues tomorrow, please log a support ticket so the team can review and address them promptly.
Posted Dec 11, 2025 - 18:19 GMT
This incident affected: New Software Release.